Library systems, including Primo the library catalogue unavailable

Incident Report for Prifysgol Aberystwyth University

Resolved

This incident has been resolved.
Posted Jul 15, 2026 - 09:16 BST

Update

We are continuing to monitor for any further issues.
Posted Jul 13, 2026 - 17:26 BST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 13, 2026 - 17:25 BST

Investigating

Primo, the library catalogue, and library self service kiosks are currently unavailable. This is due to a system outage affecting our cloud based library systems, which is being looked into urgently by our system supplier.
Posted Jul 13, 2026 - 17:03 BST
This incident affected: Library Systems (Alma, Primo Library Catalogue).