Possible Disruption to Student Record

Scheduled for Jun 9, 07:00 - 09:00 BST

Update

Service Student Record may be disrupted while we undertake essential maintenance work.
Posted Jun 04, 2026 - 09:25 BST

Update

We will be undergoing scheduled maintenance during this time.
Posted Jun 04, 2026 - 08:41 BST

Scheduled

Service O365mfaproxy1 will be offline for approximately 60 minutes to perform essential maintenance work.
Posted Jun 04, 2026 - 08:40 BST
This scheduled maintenance affects: Student Systems (Student Record).