Disruption to University website

Incident Report for Prifysgol Aberystwyth University

Resolved

This incident has been resolved.
Posted Sep 01, 2025 - 10:27 BST

Monitoring

A fix has been implemented and the University website is now available. However, the website should be considered at risk while we monitor the situation.
Posted Aug 22, 2025 - 17:58 BST

Investigating

The University website is unavailable. We are continuing to investigate the problem.
Posted Aug 22, 2025 - 15:30 BST

Monitoring

A fix has been implemented and the University website is now available. However, the website should be considered at risk while we monitor the situation.
Posted Aug 22, 2025 - 13:37 BST

Investigating

We are currently investigating an issue affecting the University's website.

Updates and an expected resolution time will be posted as soon as they are available.
Posted Aug 22, 2025 - 13:23 BST
This incident affected: Business Systems (aber.ac.uk website).