Disruption to AU Website

Incident Report for Prifysgol Aberystwyth University

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 05, 2025 - 19:32 GMT

Update

We are continuing to investigate this issue.
Posted Dec 05, 2025 - 17:32 GMT

Investigating

We are investigating an issue affecting the www.aber.ac.uk website.

Updates and an expected resolution time will be posted as soon as they are available.
Posted Dec 05, 2025 - 17:31 GMT
This incident affects: Business Systems (aber.ac.uk website).