"M" drives / Central filestore issues

Incident Report for Prifysgol Aberystwyth University

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 06, 2026 - 13:12 GMT

Investigating

We are currently investigating an issue affecting access to M: drives.
Posted Mar 06, 2026 - 13:09 GMT
This incident affects: Storage (M Drives).