Disruption to AStRA service

Incident Report for Prifysgol Aberystwyth University

Resolved

This incident has been resolved and access to the AStRA service has been restored.
Posted Dec 04, 2025 - 12:41 GMT

Investigating

We are investigating an issue affecting the AStRA service. This only affects the AStRA client and MyAdmin applications continue to be available.
Posted Dec 04, 2025 - 11:41 GMT
This incident affected: Business Systems (AStRA).