Disruption to M: Drives

Incident Report for Prifysgol Aberystwyth University

Resolved

This incident has been resolved.
Posted Oct 09, 2025 - 16:59 BST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 30, 2025 - 17:45 BST

Investigating

We are currently investigating reports that some users are unable to access their M: Drives.

This issue affects accounts provisioned in recent months.

Updates and an expected resolution time will be posted as soon as they are available.
Posted Sep 30, 2025 - 17:29 BST
This incident affected: Desktop Services (Windows, Guacamole (rd.aber.ac.uk)), Other Services (central.aber.ac.uk), and Storage (M Drives).