Digital Discovery Tool outage

Incident Report for Prifysgol Aberystwyth University

Resolved

This incident has been resolved.
Posted Sep 15, 2026 - 16:52 BST

Identified

New students unable to sign in to the Jisc Digital Discovery Tool
Posted Sep 15, 2026 - 16:46 BST
This incident affected: Library Systems (Digital Discovery Tool).