Disruption to ABW Web Access

Incident Report for Prifysgol Aberystwyth University

Resolved

This incident has been resolved.
Posted Feb 17, 2026 - 13:59 GMT

Monitoring

Access to ABW has now been restored. Technical colleagues will continue to monitor the service throughout the day.
Posted Feb 17, 2026 - 12:56 GMT

Investigating

We are investigating an issue affecting web access to ABW.

Updates and an expected resolution time will be posted as soon as they are available.
Posted Feb 17, 2026 - 12:38 GMT
This incident affected: Business Systems (ABW).