Disruption to Calm Ticketing service

Incident Report for Prifysgol Aberystwyth University

Resolved

This incident has been resolved.
Posted May 12, 2026 - 11:48 BST

Investigating

We are investigating an issue affecting Calm Ticketing service.

Updates and an expected resolution time will be posted as soon as they are available.
Posted May 12, 2026 - 10:38 BST
This incident affected: Business Systems (CALM Ticketing System).