PURE Admin Portal Unavailable

Incident Report for Prifysgol Aberystwyth University

Resolved

The issue has been resolved and the service is available once more.
Posted Aug 14, 2025 - 07:05 BST

Investigating

The PURE admin portal is currently unavailable.
Posted Aug 13, 2025 - 17:16 BST
This incident affected: Other Services (Pure).