Turnitin Receipts

Incident Report for Prifysgol Aberystwyth University

Resolved

This incident has been resolved.
Posted Mar 04, 2026 - 07:48 GMT

Identified

There is an issue affecting Turnitin submission receipt downloads.

We have raised with Turnitin and are monitoring the situation.

We apologise for any inconvenience caused.
Posted Feb 23, 2026 - 13:15 GMT
This incident affected: Student Systems (Turnitin).