Turnitin, Panopto & Talis Aspire - currently not working

Incident Report for Prifysgol Aberystwyth University

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 14:09 BST

Investigating

Following the disruption caused by the Amazon Webserver Outage, Turnitin, Panopto, and Talis Aspire should be considered at risk until further notice.
Posted Oct 20, 2025 - 11:16 BST
This incident affected: Student Systems (Panopto, Turnitin).