Turnitin is currently unavailable

Incident Report for Prifysgol Aberystwyth University

Resolved

This incident has been resolved.
Posted Mar 12, 2026 - 07:32 GMT

Investigating

There is currently an issue affecting Turnitin.

We have reported the issue to Turnitin who are investigating.

Please accept our apologies for any inconvenience caused.
Posted Mar 11, 2026 - 17:03 GMT
This incident affected: Student Systems (Turnitin).