Possible disruption to IT services following power outage

Incident Report for Prifysgol Aberystwyth University

Resolved

All IT services remained operational during the outage.
Posted Sep 25, 2025 - 16:08 BST

Investigating

Following a power outage, we are making sure all IT services are available. We will add information here as we know more.
Posted Sep 25, 2025 - 11:17 BST