Further disruption to PAU-Guest wireless network

Incident Report for Prifysgol Aberystwyth University

Monitoring

A fix has been implemented and we are continuing to monitor the PAU-Guest network in collaboration with our external supplier.
Posted Mar 30, 2026 - 18:20 BST

Investigating

We are aware of further issues with the PAU-Guest wireless network resulting in connectivity issues and slow speeds.

We are investigating the root cause of the issue in collaboration with our external service provider and will provide an update once available.
Posted Mar 30, 2026 - 13:09 BST
This incident affects: Network (Wi-Fi Network (PAU-Guest)).