Issue with Microsoft Office software licensing
Incident Report for Prifysgol Aberystwyth University
Resolved
We believe the issues with Microsoft Office licensing have now been resolved. If you are still experiencing trouble with licensing Microsoft Office, please contact the IT Service Desk.
Posted Nov 19, 2024 - 09:06 GMT
Investigating
We are aware of an issue with Microsoft Office software (Word, Excel, Outlook, etc) displaying the error message "We're having trouble verifying the Office license for this device". We are investigating the cause of the issue and will provide an update as soon as we are able.

If you are unable to use your Microsoft Office software as a result of this issue, please visit https://faqs.aber.ac.uk/index.php?id=9486 or contact the IT Service Desk on 01970 622400 / is@aber.ac.uk
Posted Oct 25, 2024 - 11:35 BST
This incident affected: Desktop Services (Windows).