Disruption to AStRA

Incident Report for Prifysgol Aberystwyth University

Resolved

A fix has been identified to resolve the issue with the AStRA desktop client and a new version is now available in the Company Portal. Staff are advised to install the new version from the portal to regain access. If you have any problems updating to the new version, please contact the helpdesk.
Posted Jul 18, 2025 - 15:18 BST

Investigating

We are investigating an issue affecting the AStRA service. This only affects the AStRA client and MyAdmin applications continue to be available.

Updates and an expected resolution time will be posted as soon as they are available.
Posted Jul 17, 2025 - 10:26 BST
This incident affected: Business Systems (AStRA).